Ready to start accepting credit cards? Get Started

How will I be affected by my payment gateway requiring TLS 1.2?

Many payment gateways have announced a requirement for TLS 1.2 starting in 2018. We expect almost all of the payment gateways we support to require TLS 1.2 by the end of summer 2018.

TLS 1.2 is a security protocol that is used when your device connects to the payment gateway. TLS stands for Transport Layer Security. Earlier versions of this protocol were referred to as SSL (Secure Sockets Layer). This is the family of protocols that is used for connecting to https resources.

Please refer to the list below to see which operating system versions are required to connect to gateways requiring TLS 1.2.

Errors arising from this problem vary greatly from system to system, but usually the error message will refer to “certificate” or “protocol”.

The best way to resolve these kinds of errors is to upgrade your operating system to one that is supported. Certain Android devices may not be able to upgrade, depending on the manufacturer and wireless carrier. Unfortunately, these older Android devices will not be able to connect to payment gateways requiring TLS 1.2.

iOS: 6 and newer

macOS: 10.9 Mavericks and newer

Windows: 8.1 and newer (app version 1.16 or newer)

Windows Phone: Not supported.

Android: 5.0 and newer (4.1 and newer with app version 3.21 or newer)

Ready to start accepting credit cards? Get Started